Support

iDream Media is compatible with any PC or Mac using a supported browser with the latest version of the Adobe Flash player installed. It is also compatible with select mobile and TV-supported devices via the free iDream Media app.

System Requirements: Adobe Flash Player 10.1 (.53.64) or above (If you don't have the latest version, download it here) Internet Explorer 9.0 or above, Firefox 18.0 or above, Safari 5.0 or above, or Chrome Microsoft Windows XP SP2 or above, Macintosh OS X 10.4 or above, or Linux JavaScript and cookies enabled

Troubleshooting video streaming issues Check your bandwidth Pause or close other applications Move your device closer to your Internet connection Be sure to have the latest version of Flash software installed Try another compatible browser Try restarting your home network

Contact support by dropping a mail to: support@idreammedia.com